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WHY AM | READING THIS MANUAL?

If you have purchased an HC12 module, with a docking module, from
Technological Arts and are wondering what to do next, you are at the right place!

Or, if you have been accustomed to programming in assembly for most of your
career and you want to get your feet wet in embedded C, using CodeWarrior 3.0,
then this manual should give you a good start.

Before you dive in and start creating robots or an alarm system to alert you about
visiting in-laws, you will need an overview of the CodeWarrior 3.0 environment
to get you started.

This graphic oriented step-by-step guide will show you how to:

Create a project

Write a simple source code, using embedded C

Make file

Download the code to your HC12 module

Pat yourself on the back when you have completed this task and then gloat
to your friends about how you spent $130 to press buttons and see lights
turn on.

You can program the HC12 to do a lot more once you have become
familiarized with programming some of the many features of the HC12 including:

Timer functions to measure frequencies or generate pulses to vary motor
speed among other things

Analog to Digital Conversion for extracting data from the outside world
The SCI and SPI for communicating with asynchronous and synchronous
peripherals respectively (keyboards, mice, monitors etc.)

Parallel ports to interface to a variety of devices including LCD and seven
segment displays

Combining some or all of these features together to create some incredible
projects

NOTE: Programming of the HC12’s features is beyond the scope of this manual.

These topics will appear in future manuals from Technological Arts.

Getting started is as simple as it sounds.

SO LETS GET STARTED!
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GETTING STARTED

We have assumed that you have already installed Metrowerks CodeWarrior 3.0

on your PC. If not, there is a guide included in your HC12 kit that shows you how
to install CodeWarrior and how to obtain a license.

STEP 1 — CREATING YOUR FIRST PROJECT

a. If code Warrior is not already open, you can start the application by selecting:
Start>Programs>Metrowerks CodeWarrior>CW12 3.0> CodeWarrior IDE

b. Figure 1-The Metrowerks CodeWarrior window will pop up:

{5 Metrowerks Code'Warrior =10 x|
File Edit Mjew Search Project Debug  Processor Expert Sindow  Help

=R IR S Y FEREJARL BY BEN

Figure 1

¢. From the Menu bar, select File > New
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Figure 2 - The New dialog box will popup. Under the Project tab:

e Select HC(S)12 New Project Wizard

* Type “example” in the Project name textbox (However, the Project Name
can be any name you want)

* Specify the location where you want to save the project

* Click OK

g
Proiect | File | Obiect |
E Empty Project Froject name:
"’@ HC[S1 2 Mew Project “wizard Ie:-cample

S HCS1 2 Stationeny
Location:

IC:"-.DDc:uments and Settingshker Set. ..

Add ta Project:
Froject:

| =

Ok I Cancel I

Figure 2

Figure 3- Select the HC12 derivative that you will be programming. In this
case we have selected the MC9S12C32.

WARNING: Selecting the wrong derivative will cause problems when you
program your board!

Click Next

MNew Project Wizard - Page 1 |

Select the derivative pou would like o use.

Derivakives e
FMCEEHCS1 284

MCEGHC21 2652

MCeEHC91 2060

MIESHI9 120605

MCESHCD1 Z0E1 25

MIESHIZD1Z20DG1 258

MCEGHC21ZDT125

FMCESHCID12DT1 255 —_—
MC951 281256

9512825068

MCIS 12852

MCI512a512

M5 1 =869

M35 =
MMIZ9S12052

LN

metrowerks MeaS 12064 -

BOfT s e St rte Moo

B e A

< Back I Mex=t = I Cancel I

Figure 3
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f. Figure 4-Check off C and click Next

New Project Wizard - Page 2 x|
Pleasze chooze the st of languages to be
supported initially. “ou can make multiple
zelections.
SSBI‘I‘Ib|
[
[1C++
T hiz waill =t up pour application with a .&NSI-C;I
caompliant ztartup code [doing initialization of
global wariables].
metrowerks
Boftwware Storte MHors A ;I
< Back I Hext = I Cancel I
Figure 4
g. Figure 5- Select No for processor expert
Mew Project Wizard - Page 3 =

LN\

metrowerks

Bofiware Stecte Hoeoes -

wwould you like to uze Proceszor E spert?

Mo dewvice intialization code iz generated. “I
Only generates startup code.

I

< Back I Mest » I Cancel

Figure 5
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h. Figure 6-Select No for PC-Int

Mew Projeckt Wizard - Page 4
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=l
FLC-lint iz a product from Gimpel Software. -
o heed the PC-lint zoftware from Gimpel
installed in order to use the Codew arrior
m plugir. - I
metrowerks
Boftware Sterte Hore
< Baclk I Hex=t > I Cancel I
Figure 6
i. Figure 7- Select None for float point format
Mew Project Wizard - Page 5 =]
Select the floating point format supported.
Select 'Mone’ for best code density.
= float iz IEEE3Z. double is IEEE 32
" float iz IEEE32. double iz IEEEE4
D on't uze floating point support. AI
=
metrowerks
Boftware Sierte Hore <4
< Back I Mex=t = I Cancel I
Figure 7

Almost there!!!!
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k. Figure 8- Select Small for memory model

New Project Wizard - Page & |
WWrhich memory model zhall be uzed?
T Large
The small mermory maodel i best suited if bath the .«
code and the data do fit into the B4 KB address
space.
By default all wariablez and functionz are
accezsed with 16 bit addresses. The compiler
i ‘ does zupport banked functions or paged
wariables in this memory model, howewver ;I
metrowerks
Boftware Starte Hors o
< Back I Hex=t » I Cancel I
Figure 8
I. Figure 9-

*  Uncheck Metrowerks Full Chip Simulator

*  Check Motorola Serial Monitor Hardware Debugging

* Click Finish

* Getready to code!

Mew Project Wizard - Page 7 =4

metrovwwerks

Boftware Storte MHoro

FPleaze choosze the connections you want. Wou can

zelect multiple connections.

[k etrawerks Full Chip Simulatar

[ 1F&E Hardware Debugging

[ 1inDAaRT-HCS12 Hardware Debugging
[IAabatron Hardware D ebugging
Fdrdotorola Senal Monitor Hardware Debunaing

T hiz target interface connects ko an an-chip AI
zerial monitor for HCS1 2 devices.

I

< Back I Einizh I Cancel

Figure 9
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STEP 2 - LETS WRITE SOME SOURCE CODE

* Figure 10-This is your new project window. Expand the Sources folder by
clicking on the [+] and double click on main.c

HEMetrowerks CodeYarrior — ||:I| X|

File Edit Wew Search Project Debug Processor Experk  window Help

BME S H < hABAAANESIE »HER
==

example mcp I

I honitar j B o @ G -
Files I Link Order I Targets I
“ | File | Code | Data [w# [ -]
BB readme. st nia nia =
w =S Sources a 0 - =
3 B Wrain.c u] 0« =
w [F{] Startup Code u} 0o s =
“ =3 Prm u] u] =l
F_1 Linker Map u] u] =l
% [+{_] Libraries u] 0« =
=-{_3 Debugger Praoject File u] u] =l
{3 Debugger Crnd Files u] u] =l
[
14 files u] a
Figure 10

* Figure 11-The source code window called main.c should popup. This is
where you write the source code (the embedded C code) for your project

iMetrowerks CodeWarrior _||:||5|
Fle Edit Wew Sesrch Project Debug Processor Expert Window Help

BEslarx<haaRaNEEREER

1 [ -
I % Moritor j ’Ej v @ 5‘ > b -nm- + o~ Path |E'\Dncuments and Settings\KennethexampledSourcesimain c
. #include <hidef . h> 7% common defines and macros 7
Fil
183 |L|nkD|de|| Targetsl #include <mc9s12c32 he #% derivative information */
¢ | Fie | Code | Data |9 [=]
readme. bt nla nla = fpragma LINE_INFO DERIVATIVE "mc9=s12c32
1] =
# E1443 Sources 0 0« = R .
¢ - OEE 0 0 = void main(woid) {
@ [#{_] Startup Code 0 0 = <% put your own code heres %/
Enablelnterrupts;
# @3 Pm 0 0« for(::) {} <= wait forever =~
®{] Lirker Map 0 0 = o
¥ [#{_] Libraries 0 0+ = —
{23 Debugger Project File 0 0 =
{23 Debugger Crad Files 0 0=

El B
14 files 1] 1] 4| »
4

Figure 11
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* Table 1-Delete the contents of the main.c window and copy and paste the
following code into the source code window (main.c). Select File>save.

#include <hidef.h> /* common defines and macros */
#include <mc9s12c¢32.h> /* derivative information */
#pragma CODE_SEG DEFAULT
void main(void)
{

DDRT = 0x03;

ATDCTL23 = 0x0;

ATDCTLA45 = 0x0;

ATDDIEN = 0xFF;

while(1)

{

PTT = ~(PTAD/64);

}

}

Table 1

STEP 3 - COMPILING YOUR CODE

e From the menu bar select: File > Project > Make
Optionally you could just press function F7 on your keyboard

* Figure 12-This step will compile your code and display any errors in or
warnings in the Errors & Warnings window as shown. For now ignore the
warnings. If you have any errors, double check the code to make sure you
have copied and pasted everything correctly

~1ol x|
Iﬁ | [} I& | o I | 1 | Errors and warnings far "t &I = I = I
E | CA000: Condition always TRUE u

main.c line 13
=
_>l_I

b - + m' ~ Path: | C:xDocuments and SettingsiKennethitesti Smaine <>

A=

Finclude <mc9=12c32 he <% derivative information - al
#pragma CODE_SEG DEFAULT ;I

wold mainfwvoid)

1
DDRET = 0=03: |
ATTCTT.Z23 = Nw=n-

Figure 12
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STEP 4 - PROGRAMMING THE HC12 BOARD

Congratulations on making it this far! We are now on the last few stages.

PART 4a - Connecting your HC12 module

*  With your HC12 module out of the box connect the 9V power supply
which is included with your kit.

* Connect the serial cable, included with your kit, between the serial
port of your PC and the female serial connector of the HC12 module

* Make sure that switch SW1 on the module is in BOOT mode

* Plug in the power supply

PART 4b - Downloading your Assembled program

* Figure 12-On the new.mcp tab click on the debug button

i Metrowerks CodeWarrior

File Edit Yiew Search Project Debug Processor Expert  Window Help

AEoslverx<hBaAaNEER BB R

I
[® tortor jay@ bollom-
_ #include <hi
Files |Link Drdell Targetsl lm #1221&:1: <m;
- ehug tpragma CODE

¢ | Fie | Code | Data |9 |-

B readme bt n'a nfa == void main(wo
¥ B3 Sources I SDRT = 0x03,
¥ @ mand g 0. ATDCTI23 = 6
w [#{] Startup Code a 0« = ATDOTLAS _ 0
¥ B3 Pm ¢c ¢ « ATDDIEN = Dx

{7 Lirker tMap ] ] =l
@ {7 Libraries 0 0« = hilefl
#4{_7 Debugger Project File ] I =l vhile(l)
#{_3 Debugger Cmd Files 0 o = FTT = ~{PT&D
+

Figure 13
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Figure 14 - The Monitor Setup dialog box will pop up. Select the
COM port that your HC12 module is connected to (eg. COM1, COM2,
etc). Click OK

Monitor Setup il

Monitor Communication | Laad I:Iptinjhsl

—HOST Senial Cormmunication Part:

Pleaze zelect in thiz dialog the zerial communication part Lsed
to connect to the hardware.

HOST Senal Communication Port;

— Communication protocal
[ Show Monitor TeAR

k. I Cancel

Figure 14

Figure 15- The True Time Simulator and Real-Time Debugger
window will appear

__ True-Time Simulator & Real-Time Debugger C:i\Documents and Settings' Kenneth’ new' Monikor - Ellil
Eile Wiew Run MONITOR-HCS12 Component Memory Window Help

D|s(@| &(m|e] 2| -|=|=|e|e]+] 9
T =T R

C:4\Documents and S ettingshkennethhnew’S ources\main. o |Line: 5§
woid main(woid) ;I 40)
{E 40ZE LD3E 0x4047
DDRT = 0Ox03; _I 4031 CLR Ox0011
ATDCTLES = 0x0; 4034 LDAE  #57 -
ATDCTL4AS = 0x0;
* 4] | .z

ATDDIEN = 0xFF;

;I Register _|EI|5|
whi el T T &
ol o4 fos [0 4

IX a I¥ 1)
Startup () ﬂ IP | 4029 PC [4029  PPAGE [3F =]
= — —=1 "
AT ol
Statl2.c Auto | Symb [ Global At
_startupData £23> _tagitartup ooooso 00 00 00 20 LI
oooos4 05 00 00 00
nnnn&Es &Nonoonnonn ... LI
e e
_Startup Ao [ Spmb | Local Postload command file correctly execuj‘
in hd
] | oz
For Help, press F1 |Automatlc (triggers, breakpoints, watchpoints, and trace possible) |MC9512C &

Figure 15
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* Figure 16 - In the Command Window at the bottom right of the True
Time Simulator and Real-Time Debugger, figure 16, type GO as
shown and hit enter.

_iix

F S

ine=go

STARTELD

RUNNING

monitor is in reset state _I
-
v

ir=0
1 I I k

Figure 16

e Switch SW1 on the HC12 module into RUN mode and press reset.
This should start the program

* The program should now be running. Pressing the user buttons SW2
and SW3, on the docking module, should turn on LEDS D2 and D3
respectively.

* CONGRATULATIONS you have now completed your first embedded
C program using CodeWarrior

CONCLUSION

You have now learned how to create project, where to write the source code, how
to compile the source code and, finally, download the project to your HC12
module. This just a tip of the iceberg. The next step is to understand the concepts
behind some of the various registers and functions that the HC12 offers, and how
to program these devices and other peripherals commonly attached to the HC12.

Of course, knowledge of the C language is important for embedded C
programming. If you are looking for a good crash course on ANSI C
programming we highly recommend the book:

The C Programming Language Second Edition. Brian W. Kernighan, Dennis
M. Ritchie. Prentice Hall Software Series.

Also keep checking back on the Technological Arts website @
www.technologicalarts.com as we will be posting how to guides on how to
interface with the commonly used features of the HC12.

www.technologicalarts.com




